読者です 読者をやめる 読者になる 読者になる

ボールを蹴りたいシステムエンジニア

ボール蹴りが大好きなシステムエンジニア、ボールを蹴る時間確保の為に時間がある時には勉強する。

Windows環境でgensimのword2vecを利用

Windows環境でgensimのword2vecを利用してみる。

環境

Windows10 64bit

前提として、
依存ライブラリである、numpyやscipyも以下リンク先よりwhlからpipインストール。

手順

http://www.lfd.uci.edu/~gohlke/pythonlibs/#gensim
にアクセスし
gensim-0.13.2-cp35-cp35m-win_amd64.whl
をダウンロード。

インストール実行

$ pip install gensim-0.13.2-cp35-cp35m-win_amd64.whl 

Processing d:\download\gensim-0.13.2-cp35-cp35m-win_amd64.whl
Requirement already satisfied (use --upgrade to upgrade): numpy>=1.3 in c:\python3.5\lib\site-packages (from gensim==0.13.2)
Requirement already satisfied (use --upgrade to upgrade): scipy>=0.7.0 in c:\python3.5\lib\site-packages (from gensim==0.13.2)
Requirement already satisfied (use --upgrade to upgrade): six>=1.5.0 in c:\python3.5\lib\site-packages (from gensim==0.13.2)
Requirement already satisfied (use --upgrade to upgrade): smart-open>=1.2.1 in c:\python3.5\lib\site-packages (from gensim==0.13.2)
Requirement already satisfied (use --upgrade to upgrade): requests in c:\python3.5\lib\site-packages (from smart-open>=1.2.1->gensim==0.13.2)
Requirement already satisfied (use --upgrade to upgrade): boto>=2.32 in c:\python3.5\lib\site-packages (from smart-open>=1.2.1->gensim==0.13.2)
Requirement already satisfied (use --upgrade to upgrade): bz2file in c:\python3.5\lib\site-packages (from smart-open>=1.2.1->gensim==0.13.2)
Installing collected packages: gensim
Successfully installed gensim-0.13.2

何かエラー出ると思ったけど大丈夫だった。
かなり嬉しい